Back
Maintenance

Server Software Upgrade

Completed 18 Jun at 02:30pm JST.

Game Server
Completed

Maintenance completed

Posted 18 Jun at 02:30pm JST.
Started

The game server will be intermittently down for few minutes due to the server upgrade.

Posted 18 Jun at 02:00pm JST.