Back
Maintenance

Maintenance

Completed 3 May at 05:00pm JST.

Game Server Dynmap
Completed

Maintenance completed

Posted 3 May at 05:00pm JST.
Started

The game server will be intermittently restarting in a while for tweaking some server configurations.

Posted 3 May at 04:15pm JST.