Back
Maintenance

Minecraft 1.18 Upgrade

Completed 1 Dec at 10:00pm JST.

Game Server Frontend Proxy Dynmap Notification Services
Completed

Posted 1 Dec at 10:00pm JST.
Started

We're applying the latest Minecraft version to our server! Please wait a moment for update completion and thank you for your cooperation.

Posted 1 Dec at 12:00pm JST.