Back
Maintenance

Minecraft 1.20 Upgrade

Completed 9 Jun at 10:30pm JST.

Game Server Frontend Proxy Dynmap
Completed

Maintenance completed

Posted 9 Jun at 10:30pm JST.
Started

Game server will be unavailable during the maintenance

Posted 9 Jun at 09:45pm JST.