Back
Maintenance

Minecraft 1.19.1 Upgrade

Completed 29 Jul at 01:00am JST.

Game Server Frontend Proxy Dynmap
Completed

Maintenance completed

Posted 29 Jul at 01:00am JST.
Started

Game server is under maintenance. We'll back soon.

Posted 28 Jul at 11:15pm JST.